当前位置: 首页 >> MySQL >> 【排错】centos7安装mariadb出现错误的解决方法 >> 正文

【排错】centos7安装mariadb出现错误的解决方法

2个月前 (10-11)     作者:Jiaozn     分类:MySQL     阅读次数:98     评论(0)    

yum安装时mariadb出现错误的解决方法

--> Finished Dependency Resolution
Error: Package: MariaDB-client-10.5.17-1.el8.x86_64 (mariadb)
           Requires: libc.so.6(GLIBC_2.28)(64bit)
Error: Package: MariaDB-server-10.5.17-1.el8.x86_64 (mariadb)
           Requires: libstdc++.so.6(CXXABI_1.3.8)(64bit)
Error: Package: MariaDB-server-10.5.17-1.el8.x86_64 (mariadb)
           Requires: libstdc++.so.6(GLIBCXX_3.4.22)(64bit)
Error: Package: MariaDB-client-10.5.17-1.el8.x86_64 (mariadb)
           Requires: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit)
Error: Package: galera-4-26.4.12-1.el8.x86_64 (mariadb)
           Requires: libssl.so.1.1(OPENSSL_1_1_1)(64bit)
Error: Package: galera-4-26.4.12-1.el8.x86_64 (mariadb)

原因版本不一致,安装mysql社区版本,但是就是想用mariadb如何办呢?


# 设置一下.repo文件,可以解决这个问题


在CentOS操作系统中/etc/yum.repos.d/目录下添加 MariaDB 的yum配置文件MariaDB.repo文件。

vim /etc/yum.repos.d/MariaDB.repo


在该文件中添加以下内容保存:

https://downloads.mariadb.org/mariadb/repositories/#distro=CentOS&distro_release=centos7-amd64–centos7&mirror=escience&version=10.5

# MariaDB 10.5 CentOS repository list - created 2021-05-30 14:43 UTC
# http://downloads.mariadb.org/mariadb/repositories/
[mariadb]
name = MariaDB
baseurl = http://yum.mariadb.org/10.5/centos7-amd64
gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
gpgcheck=1


# 清除yum的缓存并重新建立

[root@localhost src]# yum clean all

[root@localhost src]# yum makecache


除非注明,发表在“Jiaozn的博客”的文章『【排错】centos7安装mariadb出现错误的解决方法』版权归Jiaozn所有。 转载请注明出处为“本文转载于『Jiaozn的博客』原地址https://www.jiaozn.com/reed/806.html
0

评论

发表评论   

昵称*

E-mail*(建议输入,以便收到博主回复的提示邮件)

网站

分享:

支付宝

微信